Service Interruption
August 3, 2026 at 10:21 AM EDT
Resolved after 59m
Updates
Resolved
The service disruption has been fully resolved, and all systems are operating normally.
August 3, 2026 at 11:21 AM EDT
Investigating
The Zingtree technical team is actively investigating issues affecting our services. We appreciate your patience and will provide further updates as soon as we have more information.
August 3, 2026 at 10:21 AM EDT