Zingtree is unavailable
History
Resolved
Our engineers identified the issue and have restored the service
February 25 10:17 PM EST
Investigating
Our engineers our working to restore the Zingtree service. More updates to follow
February 25 10:08 PM EST