History

Resolved
November 10, 2022 4:13 PM EST

The issue is now resolved.

Identified
November 10, 2022 3:52 PM EST

We have identified the root cause and are working to remediate it.

Investigating
November 10, 2022 2:22 PM EST

We are currently investigating reports of latency when accessing the Zingtree application.