Issues with workflow rendering
June 4, 2025 at 05:38 PM EDT
Resolved after 52m
Updates
Resolved
The issue has been resolved, and services have returned to normal.
June 4, 2025 at 06:31 PM EDT
Investigating
The Zingtree technical team is actively investigating issues affecting our services.
We appreciate your patience and will provide further updates as soon as we have more information.
June 4, 2025 at 05:38 PM EDT