Zingtree is unavailable
History
Resolved
February 19, 2023 3:40 AM EST
Our engineers have isolated the issue and service has been restored
Investigating
February 19, 2023 3:35 AM EST
Our engineers our working to restore the Zingtree service. More updates to follow